PMS Information Systems
Welcome to PMS Information Systems - IBM i (AS/400) Forum !!!

Get Answers for all your queries on IBM i (AS/400).

Problem with display - Header area is not displayed

View previous topic View next topic Go down

Problem with display - Header area is not displayed

Post  rajkumar400 on Sat Dec 25, 2010 2:09 pm

Progarm A displays a screen then it calls program b it also displays a screen. When control return back to pgma the header of the screen is not displayed bot fields ( input capable ) are displayed?

Please help me.

Raj

rajkumar400

Posts : 59
Join date : 2010-12-25

View user profile

Back to top Go down

Display file issue when control returns

Post  kushaalrathi on Mon Dec 27, 2010 12:27 am

there are two ways you can handle this problem one is by

Method one:

When you refresh your program decides it did not find any
data, therefore does not turn on SFLDSP, which means
the 'subfile part' of the screen does not change. So try and turn the SFLDSP on when the
control comes back to pgma

or Method Two:

Code an ERASE(sflname) in the Control record. Condition it so it comes on when you do a SFLDSPCTL without a SFLDSP.





kushaalrathi

Posts : 12
Join date : 2010-12-26

View user profile

Back to top Go down

Re: Problem with display - Header area is not displayed

Post  rajkumar400 on Wed Dec 29, 2010 1:49 am

Thanks. I tried the both methods. It is not working.
Please note that Only header which has constants are not displayed but input fields on the subfile are displayed.

rajkumar400

Posts : 59
Join date : 2010-12-25

View user profile

Back to top Go down

Re: Problem with display - Header area is not displayed

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum